Export the Graph

Once your graph is ready, you can Export it, that is, save it for use by other programs.


Click on  File > Export. You see a window that looks a lot like the File Save window. There is a big space listing folders and files. If you want to save here, great.

If you want to save in one of the folders, double-click it to open it. If you don't like this folder, click on the  to look at other places you could save the file. You can even click   to open a new folder.

Name your file in the File Name box.


Now comes the tricky part.

Under the File Name box is this box:

I have clicked the  to see the choices. These are the file types you must choose from.


These are the types used for graphic files. Most common is JPEG (Joint Photographic Experts Group) which is the most used on the web. Most digital cameras use this format also.


Less common are GIF (Graphic Interchange File) which was popular in the 1990's, and PNG (Portable Network Graphics). There is also BMP (Windows Bitmap) which tends to produce very large files.


Which type to save as? It really depends how you intend to use the file. To post on the web, use JPEG since every browser can read it.  If the program you are going to use the file with does not accept JPEG, use a file format it will accept.


Click the format you want, and then Save. Your graph is now saved, and you can get at it from the other program (perhaps by using File > Import or Insert > File or maybe File > Open). Programs vary a lot.



For most programs, it is much easier to use Copy and Paste to move the graph from CalGraph.


If you use the File > Save or File > Save As, the graph is saved as a kag file. This enables CalGraph to open it again with every feature of your graph preserved, but no other program will open the kag file.